Server not restarting

Questions and suggestions
Post Reply
User avatar
N.O.L.F.
Clan Member
Posts: 895
Joined: 02 May 2006, 16:30
Location: In your mothers bed

Server not restarting

Post by N.O.L.F. » 08 Jul 2011, 00:06

I dunno why, but server seems to be down quite often now. it doesent restart after crashing, too. (sectore crashes it pretty often right at the beginning rsnake)
-

User avatar
Tommi
superspecial tital
Posts: 225
Joined: 12 Jul 2009, 13:19
Location: Finland

Post by Tommi » 08 Jul 2011, 00:09

Yeah, especially sectore seems to crash the server. My guess is, that at the beginning, when a lot of people are connecting into the server, it overloads it since AFAIK the update rate on the current server Zulander uses isn't as good as it was on the previous one.

E: And indeed, the server doesn't seem to restart by itself anymore.

User avatar
Zulander
Clan Member
Posts: 227
Joined: 18 Apr 2006, 11:15
Location: *Turn Around* (Finland)
Contact:

Post by Zulander » 08 Jul 2011, 12:25

The server is the same box and same version of Fedora linux. My guess is the map and or plugins are causing the crash. It is crashing the same way it did with that stupid roleplaying map - the server crashes and zombies which is why it never restarts because according to the script, the process it still running.

This requires someone to log in, look up the process, kill it, and then wait for the 10 second timer to restart it.

I have removed sectore from the mapvote.
Void me being an anxious whim.

User avatar
N.O.L.F.
Clan Member
Posts: 895
Joined: 02 May 2006, 16:30
Location: In your mothers bed

Post by N.O.L.F. » 08 Jul 2011, 13:22

ohh snap rsnake :cry: :cry: :cry:
-

User avatar
teh ORiON
NO SWAG FGT
Posts: 391
Joined: 14 Aug 2010, 17:51
Location: Denmark, Copenhagen.

Post by teh ORiON » 12 Jul 2011, 20:28

I doubt it's a problem with the map, sectorE, since there seems to be problems on other maps as well. Huge startup lag are experienced on several other maps, when the server has changed to a new map and people are connecting, the duration of the lag is around <5min, but varies alot.

SectorE still being a fairly new map, means that some still has to download the map, and in the process overload the server somehow?

I don't recall there being problems like this in the beginning of the new server, something else must be causing it, like a plugin maybe.

rSnake
Mapping Robot
Posts: 231
Joined: 08 Jan 2010, 14:17
Location: Poland
Contact:

Post by rSnake » 12 Jul 2011, 20:31

The first two weeks there was no problems with the map. I dont think it is the map itself causing the crash, more like high amount of people trying to download it at same time from the server, however, it would happen with some other maps too right?

This map has a pretty high amount of ents. Maybe someone could give it a try and disable a few plugins for it?
If its proven that the map itself is crashing due to some bug in it, it will be fine for me that its deleted. I dont feel like spending another 1,5 month on a new map which will later be deleted without a known reason.

User avatar
Zulander
Clan Member
Posts: 227
Joined: 18 Apr 2006, 11:15
Location: *Turn Around* (Finland)
Contact:

Post by Zulander » 12 Jul 2011, 23:27

We love your maps.

I didn't delete anything, I just removed it from the mapvote till this gets solved. You are one of the few tfc mappers left and we are always hungry for more. I think it is a plugin/ent problem myself but I have no idea how to fix it. That is watch's department.

Since nothing has happened till this point I suppose we need to wait for watch or someone to find out what the problem is.
Void me being an anxious whim.

craterboy
I love /d/
Posts: 1170
Joined: 11 Oct 2004, 16:13
Location: Nerdlands
Contact:

Post by craterboy » 14 Jul 2011, 13:55

I have tested a huge part of the map with Sabinette and it didn't crash. Maybe it needs more people till it crashes, but I don't think it will crash.

EDIT:

We have finished this map with 10 players and it didn't crash. So we have activated the map again.
Sorry for this problem RSnake. Hope this won't happen again.
Image

User avatar
watch
Recovering from RWI
Posts: 3063
Joined: 11 Oct 2004, 15:37
Location: UK

Post by watch » 16 Jul 2011, 00:17

I will have a gander at this in the next few days
If you hate the obnoxious signatures goto your User Control Panel and disable signatures

pizzahut
Demo
Posts: 62
Joined: 12 Aug 2009, 22:07

Post by pizzahut » 26 Sep 2011, 03:06

Sorry for bumping an old thread, it's related though.
Zulander wrote:the server crashes and zombies which is why it never restarts because according to the script, the process it still running.

This requires someone to log in, look up the process, kill it, and then wait for the 10 second timer to restart it.
The server's down since a couple of hours, are you still using a process based script? When I query your server using qstat it says

~/qstat2/qstat -nh -a2s 89.27.48.17:27015

89.27.48.17:27015 no response

Thing is, sometimes qstat will return "DOWN" instead of "no response", which I've told watch in May, so if you're using my script (which is NOT process based), you need to fix it accordingly.

http://forums.steampowered.com/forums/s ... ?t=1379885

Today's server down time might have other reasons though.

User avatar
leandros
SuperAdmin
Posts: 3157
Joined: 07 Dec 2005, 11:41
Location: Dutchelandae

Post by leandros » 26 Sep 2011, 10:12

It did, either the box or the connection died because we couldn't SSH in to fix it.
ImageImageImageImage
ImageImageImageImage
ImageImageImageImage

User avatar
Zulander
Clan Member
Posts: 227
Joined: 18 Apr 2006, 11:15
Location: *Turn Around* (Finland)
Contact:

Post by Zulander » 26 Sep 2011, 11:53

leandros wrote:It did, either the box or the connection died because we couldn't SSH in to fix it.
At about 11PM Finnish time last night, the internet line to the office was down because of a mistake made by some nearby road work (cut the line with a backhoe). It was fixed this morning.





Image
Void me being an anxious whim.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests